<!DOCTYPE html>
<html lang="en-US" xmlns:og="http://ogp.me/ns#">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Mississippi Civil Rights Museum Tells Authentic Stories from the Movement | The Madison Times</title>

<!-- All in One SEO Pack 2.7.2 by Michael Torbert of Semper Fi Web Design[169,249] -->
<meta name="description"  content="By Freddie Allen (Editor-in-Chief, NNPA Newswire) The atrium of the Mississippi Civil Rights Museum. (Mississippi Civil Rights Museum) In the early morning" />

<meta name="keywords"  content="civil rights,freddie allen,ku klux klan,mississippi civil rights museum,oseola mccarty,pamela junior,varnon dahmer sr." />

<link rel="canonical" href="https://themadisontimes.themadent.com/article/mississippi-civil-rights-museum-tells-authentic-stories-from-the-movement/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Madison Times &raquo; Feed" href="https://themadisontimes.themadent.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Madison Times &raquo; Comments Feed" href="https://themadisontimes.themadent.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/themadisontimes.themadent.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='news-pro-theme-css'  href='https://themadisontimes.themadent.com/wp-content/themes/news-pro/style.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://themadisontimes.themadent.com/wp-includes/css/dashicons.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C700%7CPathway+Gothic+One&#038;ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='sccss_style-css'  href='https://themadisontimes.themadent.com/?sccss=1&#038;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://themadisontimes.themadent.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://themadisontimes.themadent.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-tabs-stylesheet-css'  href='https://themadisontimes.themadent.com/wp-content/plugins/genesis-tabs/style.css?ver=4.9.8' type='text/css' media='all' />
<script type='text/javascript' src='https://themadisontimes.themadent.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://themadisontimes.themadent.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://themadisontimes.themadent.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='https://themadisontimes.themadent.com/wp-content/themes/news-pro/js/responsive-menu.js?ver=1.0.0'></script>
<link rel='https://api.w.org/' href='https://themadisontimes.themadent.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://themadisontimes.themadent.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://themadisontimes.themadent.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Brooke Shawver Shares Her Gun Survivor Story' href='https://themadisontimes.themadent.com/article/brooke-shawver-shares-her-gun-survivor-story/' />
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://themadisontimes.themadent.com/?p=7066' />
<link rel="alternate" type="application/json+oembed" href="https://themadisontimes.themadent.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthemadisontimes.themadent.com%2Farticle%2Fmississippi-civil-rights-museum-tells-authentic-stories-from-the-movement%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://themadisontimes.themadent.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthemadisontimes.themadent.com%2Farticle%2Fmississippi-civil-rights-museum-tells-authentic-stories-from-the-movement%2F&#038;format=xml" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//themadisontimes.themadent.com/?wordfence_lh=1&hid=B70BEF94E550ED8372DA35EF5252CA8A');
</script>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="https://themadisontimes.themadent.com/wp-content/themes/news-pro/images/favicon.ico" />
<style type="text/css">.site-title a { background: url(https://themadisontimes.themadent.com/wp-content/uploads/2015/08/header-logo-the-madison-times-paper-thats-more-than-black-and-white-nnpa-torches.png) no-repeat !important; }</style>
<meta property="og:title" content="Mississippi Civil Rights Museum Tells Authentic Stories from the Movement" />
<meta property="og:site_name" content="The Madison Times" />
<meta property="og:description" content="By Freddie Allen (Editor-in-Chief, NNPA Newswire) [caption id=&quot;attachment_7067&quot; align=&quot;alignleft&quot; width=&quot;375&quot;] The atrium of the Mississippi Civil Rights Museum. (Mississippi Civil Rights Museum)[/caption] In the early morning hours of January 10, 1966..." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://themadisontimes.themadent.com/article/mississippi-civil-rights-museum-tells-authentic-stories-from-the-movement/" />
<meta property="og:image" content="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/08/mississippi-civil-rights-museum-atrium-headline.jpg?resize=150%2C150&amp;ssl=1" />

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Mississippi Civil Rights Museum Tells Authentic Stories from the Movement" />
<meta property="og:url" content="https://themadisontimes.themadent.com/article/mississippi-civil-rights-museum-tells-authentic-stories-from-the-movement/" />
<meta property="og:description" content="By Freddie Allen (Editor-in-Chief, NNPA Newswire) In the early morning hours of January 10, 1966, civil rights leader Vernon Dahmer Sr. was jolted from his sleep, as members of the Ku Klux Klan sur…" />
<meta property="article:published_time" content="2018-08-04T23:04:45+00:00" />
<meta property="article:modified_time" content="2018-08-06T23:16:12+00:00" />
<meta property="og:site_name" content="The Madison Times" />
<meta property="og:image" content="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/08/mississippi-civil-rights-museum-atrium-headline.jpg?fit=740%2C400&amp;ssl=1" />
<meta property="og:image:width" content="740" />
<meta property="og:image:height" content="400" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@TheMadisonTimes" />
<meta name="twitter:text:title" content="Mississippi Civil Rights Museum Tells Authentic Stories from the Movement" />
<meta name="twitter:image" content="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/08/mississippi-civil-rights-museum-atrium-headline.jpg?fit=740%2C400&#038;ssl=1&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
</head>
<body class="post-template-default single single-post postid-7066 single-format-standard custom-header header-image header-full-width content-sidebar" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-main-top" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-3564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-3564"><a href="https://themadisontimes.themadent.com" itemprop="url"><span itemprop="name">Home</span></a></li>
<li id="menu-item-3561" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3561"><a href="https://themadisontimes.themadent.com/archive/" itemprop="url"><span itemprop="name">Archive</span></a></li>
<li id="menu-item-3562" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3562"><a href="https://themadisontimes.themadent.com/media-kit/" itemprop="url"><span itemprop="name">Media Kit</span></a></li>
<li id="menu-item-3563" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3563"><a href="https://themadisontimes.themadent.com/contact-us/" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
<li class="right search"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://themadisontimes.themadent.com/" role="search"><meta itemprop="target" content="https://themadisontimes.themadent.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search this website &#x2026;" /><input type="submit" value="Search"  /></form></li><li class="right date">August 6, 2018</li></ul></div></nav><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://themadisontimes.themadent.com/">The Madison Times</a></p><p class="site-description" itemprop="description">The Paper That&#039;s More Than Black and White</p></div></div></header><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-main-categories" class="menu genesis-nav-menu menu-primary"><li id="menu-item-3590" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-3590"><a href="https://themadisontimes.themadent.com/sections/news/" itemprop="url"><span itemprop="name">News</span></a>
<ul class="sub-menu">
	<li id="menu-item-3588" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3588"><a href="https://themadisontimes.themadent.com/sections/news/local-news/" itemprop="url"><span itemprop="name">Local News</span></a></li>
	<li id="menu-item-3591" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-3591"><a href="https://themadisontimes.themadent.com/sections/news/national-news/" itemprop="url"><span itemprop="name">National News</span></a></li>
	<li id="menu-item-3585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3585"><a href="https://themadisontimes.themadent.com/sections/news/international-news/" itemprop="url"><span itemprop="name">International News</span></a></li>
	<li id="menu-item-3592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3592"><a href="https://themadisontimes.themadent.com/sections/news/sports-news/" itemprop="url"><span itemprop="name">Sports News</span></a></li>
	<li id="menu-item-3581" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3581"><a href="https://themadisontimes.themadent.com/sections/education/" itemprop="url"><span itemprop="name">Education News</span></a></li>
</ul>
</li>
<li id="menu-item-3577" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-3577"><a href="https://themadisontimes.themadent.com/sections/columns/" itemprop="url"><span itemprop="name">Columns</span></a>
<ul class="sub-menu">
	<li id="menu-item-3576" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3576"><a href="https://themadisontimes.themadent.com/sections/columns/columnists/" itemprop="url"><span itemprop="name">Columnists</span></a></li>
	<li id="menu-item-3593" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3593"><a href="https://themadisontimes.themadent.com/sections/columns/opinion-editorial/" itemprop="url"><span itemprop="name">Editorials</span></a></li>
	<li id="menu-item-3578" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3578"><a href="https://themadisontimes.themadent.com/sections/columns/letters-to-the-editor/" itemprop="url"><span itemprop="name">Letters to the Editor</span></a></li>
	<li id="menu-item-3586" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3586"><a href="https://themadisontimes.themadent.com/sections/columns/life-lessons-with-alex-gee/" itemprop="url"><span itemprop="name">Life Lessons with Alex Gee</span></a></li>
</ul>
</li>
<li id="menu-item-3582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3582"><a href="https://themadisontimes.themadent.com/sections/events/" itemprop="url"><span itemprop="name">Events</span></a></li>
<li id="menu-item-3584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3584"><a href="https://themadisontimes.themadent.com/sections/health-matters/" itemprop="url"><span itemprop="name">Health</span></a></li>
<li id="menu-item-3583" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3583"><a href="https://themadisontimes.themadent.com/sections/finance/" itemprop="url"><span itemprop="name">Finance</span></a></li>
<li id="menu-item-3587" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3587"><a href="https://themadisontimes.themadent.com/sections/lifestyle/" itemprop="url"><span itemprop="name">Lifestyle</span></a></li>
<li id="menu-item-3575" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3575"><a href="https://themadisontimes.themadent.com/sections/classifieds-employment/" itemprop="url"><span itemprop="name">Classifieds</span></a></li>
<li id="menu-item-3579" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-3579"><a href="https://themadisontimes.themadent.com/sections/community/" itemprop="url"><span itemprop="name">Community</span></a>
<ul class="sub-menu">
	<li id="menu-item-3580" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3580"><a href="https://themadisontimes.themadent.com/sections/community/middle-spread/" itemprop="url"><span itemprop="name">Middle Spread</span></a></li>
</ul>
</li>
<li id="menu-item-3589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3589"><a href="https://themadisontimes.themadent.com/sections/milwaukee-page/" itemprop="url"><span itemprop="name">Milwaukee</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><div class="above-article">
          	
</div> <article class="post-7066 post type-post status-publish format-standard has-post-thumbnail category-headline category-national-news category-news tag-civil-rights tag-freddie-allen tag-ku-klux-klan tag-mississippi-civil-rights-museum tag-oseola-mccarty tag-pamela-junior tag-varnon-dahmer-sr entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Mississippi Civil Rights Museum Tells Authentic Stories from the Movement</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2018-08-04T18:04:45+00:00">August 4, 2018</time></p></header><div class="entry-content" itemprop="text"><p><strong>By Freddie Allen </strong><br />
<strong>(Editor-in-Chief, NNPA Newswire)</strong></p>
<div id="attachment_7067" style="width: 385px" class="wp-caption alignleft"><img class="size-full wp-image-7067" src="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/08/mississippi-civil-rights-museum-atrium.jpg?resize=375%2C250&#038;ssl=1" alt="" width="375" height="250" srcset="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/08/mississippi-civil-rights-museum-atrium.jpg?w=375&amp;ssl=1 375w, https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/08/mississippi-civil-rights-museum-atrium.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 375px) 100vw, 375px" data-recalc-dims="1" /><p class="wp-caption-text">The atrium of the Mississippi Civil Rights Museum. (Mississippi Civil Rights Museum)</p></div>
<p>In the early morning hours of January 10, 1966, civil rights leader Vernon Dahmer Sr. was jolted from his sleep, as members of the Ku Klux Klan surrounded his house just north of Hattiesburg, Miss. Dahmer, a Black land-owner, had been actively working to register Blacks to vote and, in some cases, he even paid their “poll” taxes. It was enough to earn a Black man a death sentence in the South.</p>
<p>The Klansmen bullets ripped through the darkness, splintering wood and shattering glass as they fired on Dahmer’s house; one of them hurled a Molotov cocktail through the window; the Klan wanted to burn Dahmer and his family alive.</p>
<p>As smoke and flames engulfed his home, Dahmer grabbed his shotgun and <span id="IL_AD6" class="IL_AD">blasted</span> his way out, creating a diversion as the rest of his family fled into the woods. Later that day, Dahmer died from smoke inhalation at an area hospital.</p>
<p>A few days later, Dahmer’s voter registration card arrived in the mail.</p>
<p>“These are the kinds of stories we talk about in the Mississippi Civil Rights Museum,” said Pamela Junior, the museum’s director. “We tell people <span id="IL_AD3" class="IL_AD">all the time</span>: Museums are living and breathing places.”<br />
Junior lamented that, oftentimes, the history of the Civil Rights Movement is told through the narrow lens of a few key figures, like Martin Luther King, Jr. and Rosa Parks. She said that it was important that people know that Mississippi was ground zero for the Movement; the Mississippi Civil Rights Museum helps to tell the stories of the people that were there.</p>
<p>“What we want to do is make sure that the stories are told authentically,” Junior said. “We have our own native son, Medgar Wiley Evers. We have Fannie Lou Hamer, June Johnson, Owen Brooks…local people who made up the Movement.”</p>
<p>Junior said that it was also important to show that civil rights leaders were ordinary people, yet they still managed to have a significant impact on the course of <span id="IL_AD4" class="IL_AD">American</span> history.</p>
<div id="attachment_7068" style="width: 384px" class="wp-caption alignright"><img class="size-full wp-image-7068" src="https://i0.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/08/exhibit-commemorating-jackson-public-library-sit-ins-mississippi-civil-rights-museum.jpg?resize=374%2C250&#038;ssl=1" alt="" width="374" height="250" srcset="https://i0.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/08/exhibit-commemorating-jackson-public-library-sit-ins-mississippi-civil-rights-museum.jpg?w=374&amp;ssl=1 374w, https://i0.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/08/exhibit-commemorating-jackson-public-library-sit-ins-mississippi-civil-rights-museum.jpg?resize=300%2C201&amp;ssl=1 300w" sizes="(max-width: 374px) 100vw, 374px" data-recalc-dims="1" /><p class="wp-caption-text">Exhibit commemorating the Jackson Public Library sit-ins. (Mississippi Civil Rights Museum)</p></div>
<p>Junior continued: “So, to see something so powerful that these regular, poor people did to make things happen in the state of Mississippi is awesome.”</p>
<p>The Mississippi Civil Rights Museum opened on December 9, 2017. The Clarion Ledger reported that the Dahmer family donated a truck that had been shot during the 1966 attack to the Mississippi Civil Rights Museum.</p>
<p>The museum promotes a greater understanding of the Civil Rights Movement in Mississippi and shares the stories of the movement that <span id="IL_AD2" class="IL_AD">changed</span> the world.</p>
<p>A press release that described the museum said that visitors can witness the freedom struggle in eight interactive galleries that show the systematic oppression of Black Mississippians and their fight for equality that transformed the state and nation.</p>
<p>The press release continued: “Seven of the galleries encircle a central space called ‘This Little Light of Mine.’ There, a dramatic sculpture glows brighter and the music of the Movement swells as visitors gather.”</p>
<p>Each museum gallery highlights a specific sub-topic or period. Gallery 1 defines civil and human rights; Gallery 2 focuses on the <span id="IL_AD10" class="IL_AD">Civil War</span> and Reconstruction; Gallery 3 highlights civil rights activists and shares the stories of a Mississippi movement that changed the world; Gallery 4 peels back the layers of a segregated society; Gallery 5 showcases the sacrifices and the successes of the 1960s; Gallery 6 takes a deep dive into the Freedom Summer and local movements in Mississippi (1963-1964); and Gallery 7 tells the story of Black Empowerment from 1965 to the early 1970s.</p>
<p>Junior said that, through the civil rights museum, the ills of Mississippi are finally on the wall.</p>
<p>“We’re taking the bandage off of the sore,” Junior said. “We don’t allow it to fester anymore. We let it breathe, so that healing can continue.”</p>
<p>The last gallery, Junior said, was designed to spark <span id="IL_AD11" class="IL_AD">conversations</span> about how all races can move forward together.</p>
<p>“Martin is gone. Medgar is gone. All these people are gone that were at the <span id="IL_AD8" class="IL_AD">center</span> of the movement, at the forefront. We <span id="IL_AD5" class="IL_AD">believed</span> in them and trusted in them. These people are gone,” Junior said. “So, what we want to do is teach people that they are the movement.”</p>
<p>Junior continued: “We are the movement; it’s up to us to do the work.”</p>
<p>Gallery 8 is titled “Where do we go from here?” and features mirrors with quotes from Mississippians who made incredible sacrifices to improve the lives of others.</p>
<p>One of the last quotes that visitors see as they walk out of the Mississippi Civil Rights Museum is by Oseola McCarty, a Black seamstress and domestic worker who lived in Hattiesburg, Miss. McCarty, who “quit school in the sixth grade to go to work, never married, never had children and never learned to drive,” according to The New York Times, eventually donated nearly her entire life savings—$150,000—to the University of Southern Mississippi to fund scholarships for Black students.</p>
<p>“[McCarty] said that, ‘if you want to be proud of yourself, you have got to do things you can be proud of,’” Junior said. “So, I want people to live by that mantra.”</p>
<p><strong><em>For more information about the Mississippi Civil Rights Museum, <span id="IL_AD1" class="IL_AD">please visit</span></em> <a onclick="javascript:pageTracker._trackPageview('/outgoing/www.mcrm.mdah.ms.gov/');"  href="http://www.mcrm.mdah.ms.gov/" target="_blank" rel="noopener">http://www.mcrm.mdah.ms.gov/</a>.</strong></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="https://themadisontimes.themadent.com/article/mississippi-civil-rights-museum-tells-authentic-stories-from-the-movement/" data-layout="button_count"></div></li><li class="share-twitter"><a onclick="javascript:pageTracker._trackPageview('/outgoing/twitter.com/share');"  href="https://twitter.com/share" class="twitter-share-button" data-url="https://themadisontimes.themadent.com/article/mississippi-civil-rights-museum-tells-authentic-stories-from-the-movement/" data-text="Mississippi Civil Rights Museum Tells Authentic Stories from the Movement" data-via="TheMadisonTimes" >Tweet</a></li><li class="share-google-plus-1"><div class="googleplus1_button"><div class="g-plus" data-action="share" data-annotation="bubble" data-href="https://themadisontimes.themadent.com/article/mississippi-civil-rights-museum-tells-authentic-stories-from-the-movement/"></div></div></li><li class="share-pinterest"><div class="pinterest_button"><a onclick="javascript:pageTracker._trackPageview('/outgoing/www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fthemadisontimes.themadent.com%2Farticle%2Fmississippi-civil-rights-museum-tells-authentic-stories-from-the-movement%2F&#038;media=https%3A%2F%2Fi1.wp.com%2Fthemadisontimes.themadent.com%2Fwp-content%2Fuploads%2F2018%2F08%2Fmississippi-civil-rights-museum-atrium-headline.jpg%3Ffit%3D740%252C400%26ssl%3D1&#038;description=Mississippi%20Civil%20Rights%20Museum%20Tells%20Authentic%20Stories%20from%20the%20Movement');"  href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fthemadisontimes.themadent.com%2Farticle%2Fmississippi-civil-rights-museum-tells-authentic-stories-from-the-movement%2F&#038;media=https%3A%2F%2Fi1.wp.com%2Fthemadisontimes.themadent.com%2Fwp-content%2Fuploads%2F2018%2F08%2Fmississippi-civil-rights-museum-atrium-headline.jpg%3Ffit%3D740%252C400%26ssl%3D1&#038;description=Mississippi%20Civil%20Rights%20Museum%20Tells%20Authentic%20Stories%20from%20the%20Movement" data-pin-do="buttonPin" data-pin-config="beside"><img src="https://i0.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png?ssl=1" data-recalc-dims="1" /></a></div></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button" href="https://themadisontimes.themadent.com/article/mississippi-civil-rights-museum-tells-authentic-stories-from-the-movement/#print" rel="noopener noreferrer" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-tags">Popular Interests In This Article: <a href="https://themadisontimes.themadent.com/keywords/civil-rights/" rel="tag">Civil Rights</a>, <a href="https://themadisontimes.themadent.com/keywords/freddie-allen/" rel="tag">Freddie Allen</a>, <a href="https://themadisontimes.themadent.com/keywords/ku-klux-klan/" rel="tag">Ku Klux Klan</a>, <a href="https://themadisontimes.themadent.com/keywords/mississippi-civil-rights-museum/" rel="tag">Mississippi Civil Rights Museum</a>, <a href="https://themadisontimes.themadent.com/keywords/oseola-mccarty/" rel="tag">Oseola McCarty</a>, <a href="https://themadisontimes.themadent.com/keywords/pamela-junior/" rel="tag">Pamela Junior</a>, <a href="https://themadisontimes.themadent.com/keywords/varnon-dahmer-sr/" rel="tag">Varnon Dahmer Sr.</a></span></p><div class="related-posts"><h3 class="related-title">Read More - Related Articles</h3><ul class="related-list"><li><a href="https://themadisontimes.themadent.com/article/panel-talks-dr-ronald-walters-legacy-black-power-and-the-black-press/" rel="bookmark" title="Panel Talks Dr. Ronald Walters’ Legacy, Black Power and the Black Press"><div class="related-image-thumb"><img width="100" height="65" src="https://i0.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/04/Black-Scholar-Activist-Ron-Walters-Was-Genius-Donna-Brazile-Says.jpg?resize=100%2C65&amp;ssl=1" class="attachment-related size-related" alt="" srcset="https://i0.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/04/Black-Scholar-Activist-Ron-Walters-Was-Genius-Donna-Brazile-Says.jpg?resize=100%2C65&amp;ssl=1 100w, https://i0.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/04/Black-Scholar-Activist-Ron-Walters-Was-Genius-Donna-Brazile-Says.jpg?zoom=2&amp;resize=100%2C65&amp;ssl=1 200w, https://i0.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/04/Black-Scholar-Activist-Ron-Walters-Was-Genius-Donna-Brazile-Says.jpg?zoom=3&amp;resize=100%2C65&amp;ssl=1 300w" sizes="(max-width: 100px) 100vw, 100px" /></div>Panel Talks Dr. Ronald Walters’ Legacy, Black Power and the Black Press</a></li><li><a href="https://themadisontimes.themadent.com/article/fair-play-charter-aimed-at-rooting-out-bias-in-the-ad-industry/" rel="bookmark" title="“Fair Play Charter” Aimed at Rooting Out Bias in the Ad Industry"><div class="related-image-thumb"><img width="100" height="65" src="https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/02/louis-jones-headline.jpg?resize=100%2C65&amp;ssl=1" class="attachment-related size-related" alt="" srcset="https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/02/louis-jones-headline.jpg?resize=100%2C65&amp;ssl=1 100w, https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/02/louis-jones-headline.jpg?zoom=2&amp;resize=100%2C65&amp;ssl=1 200w, https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2018/02/louis-jones-headline.jpg?zoom=3&amp;resize=100%2C65&amp;ssl=1 300w" sizes="(max-width: 100px) 100vw, 100px" /></div>“Fair Play Charter” Aimed at Rooting Out Bias in the Ad Industry</a></li><li><a href="https://themadisontimes.themadent.com/article/cbc-members-call-trump-presence-at-museum-opening-an-insult/" rel="bookmark" title="CBC Members Call Trump Presence at Museum Opening an Insult"><div class="related-image-thumb"><img width="100" height="65" src="https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2017/12/civil-rights-icon-representative-john-lewis.jpg?resize=100%2C65&amp;ssl=1" class="attachment-related size-related" alt="" srcset="https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2017/12/civil-rights-icon-representative-john-lewis.jpg?resize=100%2C65&amp;ssl=1 100w, https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2017/12/civil-rights-icon-representative-john-lewis.jpg?zoom=2&amp;resize=100%2C65&amp;ssl=1 200w" sizes="(max-width: 100px) 100vw, 100px" /></div>CBC Members Call Trump Presence at Museum Opening an Insult</a></li><li><a href="https://themadisontimes.themadent.com/article/black-women-will-elect-the-next-president/" rel="bookmark" title="Black Women Will Elect the Next President"><div class="related-image-thumb"><img width="100" height="65" src="https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/10/Denise-Rolark-Barnes-black-women-voters-elect-next-president-press-conference-national-press-club.jpg?resize=100%2C65&amp;ssl=1" class="attachment-related size-related" alt="" srcset="https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/10/Denise-Rolark-Barnes-black-women-voters-elect-next-president-press-conference-national-press-club.jpg?resize=100%2C65&amp;ssl=1 100w, https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/10/Denise-Rolark-Barnes-black-women-voters-elect-next-president-press-conference-national-press-club.jpg?zoom=2&amp;resize=100%2C65&amp;ssl=1 200w, https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/10/Denise-Rolark-Barnes-black-women-voters-elect-next-president-press-conference-national-press-club.jpg?zoom=3&amp;resize=100%2C65&amp;ssl=1 300w" sizes="(max-width: 100px) 100vw, 100px" /></div>Black Women Will Elect the Next President</a></li><li><a href="https://themadisontimes.themadent.com/article/was-it-civil-rights-or-a-movement/" rel="bookmark" title="Was it Civil Rights or a Movement?"><div class="related-image-thumb"><img width="100" height="65" src="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/03/people-riding-on-bus.jpg?resize=100%2C65&amp;ssl=1" class="attachment-related size-related" alt="" srcset="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/03/people-riding-on-bus.jpg?resize=100%2C65&amp;ssl=1 100w, https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/03/people-riding-on-bus.jpg?zoom=2&amp;resize=100%2C65&amp;ssl=1 200w, https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/03/people-riding-on-bus.jpg?zoom=3&amp;resize=100%2C65&amp;ssl=1 300w" sizes="(max-width: 100px) 100vw, 100px" /></div>Was it Civil Rights or a Movement?</a></li></ul></div></footer></article></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="media_image-2" class="widget widget_media_image"><div class="widget-wrap"><a href="https://themadisontimes.themadent.com/wp-content/uploads/2017/08/returning-adult-scholarship-uw-madison.jpg"><img width="800" height="1867" src="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2017/08/returning-adult-scholarship-uw-madison.jpg?fit=800%2C1867&amp;ssl=1" class="image wp-image-6499  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2017/08/returning-adult-scholarship-uw-madison.jpg?w=800&amp;ssl=1 800w, https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2017/08/returning-adult-scholarship-uw-madison.jpg?resize=129%2C300&amp;ssl=1 129w, https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2017/08/returning-adult-scholarship-uw-madison.jpg?resize=768%2C1792&amp;ssl=1 768w, https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2017/08/returning-adult-scholarship-uw-madison.jpg?resize=257%2C600&amp;ssl=1 257w" sizes="(max-width: 800px) 100vw, 800px" /></a></div></section>
<section id="text-2" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><p><a href="http://www.cityofmadison.com/HR/employment/JobOpenings.cfm" target="_blank" rel="noopener"><img src="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2017/01/hiring-laborers-city-of-madison.jpg?ssl=1" data-recalc-dims="1" /></a><a href="http://unityhealth.com" target="_blank" rel="noopener"><img src="https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/11/unity-health-insurance-uw-health.jpg?ssl=1" data-recalc-dims="1" /></a><a href="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2017/01/uw-madison-dr-martin-luther-king-education-respect-tolerance.jpg?ssl=1" target="_blank" rel="noopener"><img src="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2017/01/uw-madison-dr-martin-luther-king-education-respect-tolerance.jpg?ssl=1" data-recalc-dims="1" /></a><a href="http://milwaukeecourieronline.com" target="_blank" rel="noopener"><img src="https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/04/milwaukee-courier-newspaper-you-can-trust-since-1964-logo.jpg?ssl=1" data-recalc-dims="1" /></a><a href="http://wnov860.com/" target="_blank" rel="noopener"><img src="https://i0.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/04/wnov-860-am-the-voice-radio-logo.jpg?ssl=1" data-recalc-dims="1" /></a></p>
</div>
		</div></section>
<section id="text-11" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="https://i0.wp.com/themadisontimes.themadent.com/wp-content/uploads/2017/01/eagle-school-gifted-talented-now-accepting-applications-2017-2018.jpg?ssl=1" target="_blank"><img src="https://i0.wp.com/themadisontimes.themadent.com/wp-content/uploads/2017/01/eagle-school-gifted-talented-now-accepting-applications-2017-2018.jpg?ssl=1" data-recalc-dims="1"></a></br></br><a href="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/11/mscr-winter-spring-programs-afterschool-dance-sports.jpg?ssl=1" target="_blank"><img src="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/11/mscr-winter-spring-programs-afterschool-dance-sports.jpg?ssl=1" data-recalc-dims="1"></a></br></br><a href="https://i0.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/08/agrace-hospice-palliative-care-support-serious-illness.jpg?ssl=1"><img src="https://i0.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/08/agrace-hospice-palliative-care-support-serious-illness.jpg?ssl=1" data-recalc-dims="1"></a></br></br><a href="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/03/free-mammogram-wisconsin-well-woman-program.jpg?ssl=1" target="_blank"><img src="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2016/03/free-mammogram-wisconsin-well-woman-program.jpg?ssl=1" data-recalc-dims="1"></a></br></br><a href="https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2015/12/serges-madison-college-is-successful.jpg?ssl=1" target="_blank"><img src="https://i2.wp.com/themadisontimes.themadent.com/wp-content/uploads/2015/12/serges-madison-college-is-successful.jpg?ssl=1" data-recalc-dims="1"></a></div>
		</div></section>
<section id="text-3" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Connect With Us</h4>
			<div class="textwidget"><center><a href="http://www.facebook.com/pages/The-Madison-Times/159742987454071" target="_blank">Become Our Fan On Facebook<br /><img src="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2015/08/find_us_on_facebook_badge.gif?ssl=1" alt='Find Us On Facebook' data-recalc-dims="1" /></a><br /><br /><a href="http://www.twitter.com/themadisontimes" target="_blank">Follow Us On Twitter<br /><img src="https://i1.wp.com/themadisontimes.themadent.com/wp-content/uploads/2015/08/twitter-logo.jpg?ssl=1" alt='Follow Us On Twitter' data-recalc-dims="1" /></a></center></div>
		</div></section>
</aside></div></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="text-5" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Editorials</h4>
			<div class="textwidget"><a href="https://themadisontimes.themadent.com/keywords/karma-r-chavez/">Karma Chavez</a></br>
<a href="https://themadisontimes.themadent.com/keywords/amanda-zhang/">Amanda Zhang</a></br>
<a href="https://themadisontimes.themadent.com/keywords/julianne-malveaux/">Julianne Malveaux</a></br>
<a href="https://themadisontimes.themadent.com/keywords/benjamin-f-chavis-jr/">Benjamin Chavis</a></br>
<a href="https://themadisontimes.themadent.com/keywords/george-e-curry/">George Curry</a></div>
		</div></section>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="text-6" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Journalists</h4>
			<div class="textwidget"><a href="https://themadisontimes.themadent.com/keywords/jacklin-bolduan/">Jacklin Bolduan</a></br>
<a href="https://themadisontimes.themadent.com/?s=%22brianna+rae%22">Brianna Rae</a></br>
<a href="https://themadisontimes.themadent.com/keywords/aarushi-agni/">Aarushi Agni</a></br>
<a href="https://themadisontimes.themadent.com/?s=%22rob+franklin%22">Rob Franklin</a></br>
<a href="https://themadisontimes.themadent.com/keywords/claire-miller/">Claire Miller</a></div>
		</div></section>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="text-7" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Topics</h4>
			<div class="textwidget"><a href="https://themadisontimes.themadent.com/keywords/brown-girl-green-money/">Brown Girl Green $</a></br>
<a href="https://themadisontimes.themadent.com/keywords/young-gifted-black-series/">Young Gifted & Black</a></br>
<a href="https://themadisontimes.themadent.com/keywords/universally-speaking/">Universally Speaking</a></br>
<a href="https://themadisontimes.themadent.com/keywords/ask-progress/">Ask Progress</a></br>
<a href="https://themadisontimes.themadent.com/keywords/civil-rights/">Civil Rights</a></div>
		</div></section>
</div><div class="widget-area footer-widgets-4 footer-widget-area"><section id="text-8" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Topics</h4>
			<div class="textwidget"><a href="https://themadisontimes.themadent.com/keywords/police-shooting/">Police Shooting</a></br>
<a href="https://themadisontimes.themadent.com/keywords/police-brutality/">Police Brutality</a></br>
<a href="https://themadisontimes.themadent.com/keywords/black-lives-matter/">Black Lives Matter</a></br>
<a href="https://themadisontimes.themadent.com/keywords/naacp/">NAACP</a></br>
<a href="https://themadisontimes.themadent.com/keywords/racism/">Racism</a></div>
		</div></section>
</div><div class="widget-area footer-widgets-5 footer-widget-area"><section id="text-9" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Politicians</h4>
			<div class="textwidget"><a href="https://themadisontimes.themadent.com/?s=%22barack+obama%22">Barack Obama</br>
<a href="https://themadisontimes.themadent.com/?s=%22hillary+clinton%22">Hillary Clinton</br>
<a href="https://themadisontimes.themadent.com/?s=%22gwen+moore%22">Gwen Moore</br>
<a href="https://themadisontimes.themadent.com/?s=%22paul+soglin%22">Paul Soglin</br>
<a href="https://themadisontimes.themadent.com/?s=%22scott+walker%22">Scott Walker</div>
		</div></section>
</div><div class="widget-area footer-widgets-6 footer-widget-area"><section id="text-10" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Contact Us</h4>
			<div class="textwidget">The Madison Times</br>
313 West Beltline Hwy</br>
Suite 132</br>
Madison, WI 53713</br>
608-270-9470</div>
		</div></section>
</div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2018 &middot; <a href="http://my.studiopress.com/themes/news/">News Pro Theme</a> On <a href="http://www.studiopress.com/">Genesis Framework</a> &middot; <a href="https://wordpress.org/">WordPress</a> &middot; <a href="https://themadisontimes.themadent.com/wp-login.php">Log in</a> | Site built by <a href="http://sproutingseedsoflove.com" target="_blank">Tony Farrell</a><br />
We use third-party advertising companies to serve ads when you visit our   website. These companies may use information (not including your name, address,   email address, or telephone number) about your visits to this and other websites   in order to provide advertisements about goods and services of interest to you.   If you would like more information about this practice and to know your choices   about not having this information used by these companies, <a href="http://www.google.com/privacy_ads.html" target="_blank">click here</a>.</p></div></footer></div>
<!-- tracker added by Ultimate Google Analytics plugin v1.6.0: http://www.oratransplant.nl/uga -->
<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
var pageTracker = _gat._getTracker("UA-65981610-1");
pageTracker._initData();
pageTracker._trackPageview();
</script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/themadisontimes.themadent.com\/article\/mississippi-civil-rights-museum-tells-authentic-stories-from-the-movement\/":7066};
	</script>
<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
						<script>
			function renderGooglePlus1() {
				if ( 'undefined' === typeof gapi ) {
					return;
				}

				jQuery( '.g-plus' ).each(function() {
					var $button = jQuery( this );

					if ( ! $button.data( 'gplus-rendered' ) ) {
						gapi.plusone.render( this, {
							href: $button.attr( 'data-href' ),
							size: $button.attr( 'data-size' ),
							annotation: $button.attr( 'data-annotation' )
						});

						$button.data( 'gplus-rendered', true );
					}
				});
			}

			(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
				po.src = 'https://apis.google.com/js/platform.js';
				po.innerHTML = '{"parsetags": "explicit"}';
				po.onload = renderGooglePlus1;
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
			})();

			jQuery( document.body ).on( 'post-load', renderGooglePlus1 );
			</script>
								<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
		<script type='text/javascript' src='https://themadisontimes.themadent.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201832'></script>
<script type='text/javascript' src='https://themadisontimes.themadent.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://themadisontimes.themadent.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://themadisontimes.themadent.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://themadisontimes.themadent.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://themadisontimes.themadent.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.3.3'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type="text/javascript">jQuery(document).ready(function($) { $(".ui-tabs").tabs(); });</script>
<script type='text/javascript' src='https://stats.wp.com/e-201832.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.3.3',blog:'96841083',post:'7066',tz:'-5',srv:'themadisontimes.themadent.com'} ]);
	_stq.push([ 'clickTrackerInit', '96841083', '7066' ]);
</script>
</body></html>
<!-- *´¨)
     ¸.•´¸.•*´¨) ¸.•*¨)
     (¸.•´ (¸.•` ¤ Comet Cache is Fully Functional ¤ ´¨) -->

<!-- Cache File Version Salt:       n/a -->

<!-- Cache File URL:                https://themadisontimes.themadent.com/article/mississippi-civil-rights-museum-tells-authentic-stories-from-the-movement/ -->
<!-- Cache File Path:               /cache/comet-cache/cache/https/themadisontimes-themadent-com/article/mississippi-civil-rights-museum-tells-authentic-stories-from-the-movement.html -->

<!-- Cache File Generated Via:      HTTP request -->
<!-- Cache File Generated On:       Aug 6th, 2018 @ 11:16 pm UTC -->
<!-- Cache File Generated In:       1.20742 seconds -->

<!-- Cache File Expires On:         Aug 13th, 2018 @ 11:16 pm UTC -->
<!-- Cache File Auto-Rebuild On:    Aug 13th, 2018 @ 11:16 pm UTC -->

<!-- Loaded via Cache On:    Aug 7th, 2018 @ 5:32 am UTC -->
<!-- Loaded via Cache In:    0.02916 seconds -->